Friday, May 27, 2011

installing quickbooks 2010 Premier on a Win 2008 terminal server (32 bit)

Here's how I installed Quickbooks 2010 Premier on a Windows 2008 terminal server:

run "change user /install"
Install Quickbooks normally
When you first run Quickbooks, it asks you to choose a specific edition, but I got this error:

After some research, I tried solution #2 here:

This resolved the problem, and I was able to choose a business specific edition.

Friday, May 6, 2011

using combofix in safe mode with command prompt

I was faced with a fakealert virus yesterday that existed in safe mode also, which made cleaning it very difficult. I used the command prompt method I used a couple weeks ago to clean it. Luckily, I was on a network - not sure I would have been able to do this on a stand alone computer. Here were my steps:

[on the virus affected machine]
boot into safe mode with networking
log in as a domain admin
create new local administrator (on the chance that I didn't know the local admin password)

[from another machine in the network that is not infected]
from another machine on the network logged in as a domain admin
go to \\\c$ (affected computer drive)
create a new folder on the root of C called malware
download newest version of combofix and copy it to \\\c$\malware

[on the virus affected machine]
reboot into safe mode with command prompt
log in as local administrator
run c:\malware\combofix.exe

You won't be able to install the recovery console, but in the two times I've tried this, it hasn't been a problem.

Thursday, May 5, 2011

Google Address Book "Connection to Google is temporarily unavailable"

By default, you get an error about the google address book not being able to sync when you open a Google Apps profile in Outlook. It looks like this:

This is fixed by enabling contact sharing in the Google Apps control panel. I guess this is some kind of global address list from what I'm reading.

Here's how you fix it:
  • In the Google Apps control panel, click the Settings tab, then Contacts on the left side
  • Select Enable contact sharing.
  • Click Save changes.

And when fixed, it should work properly (though I've seen it not work - it makes little sense):