Tuesday, June 24, 2008

Sharepoint error: ‘Edit document’ requires a Windows SharePoint Services-compatible application and Microsoft Internet Explorer 5.0 or greater

I had a user get this error when trying to edit a Sharepoint doc:

I read the necessary article from MS, and it was no help:


but then I found this article:


which said that owssupp.dll add-on in IE could be disabled, which in fact was the case. So I enabled the owssupp.dll add-on in IE and then Sharepoint acted normally.

No comments: