Monday, December 14, 2009

x2upBF.dll causes Office 2007 programs to crash

For the fourth time in a month, I've come across this same issue of Office 2007 programs (other than Outlook) crashing immediately upon opening. It doesn't matter if you start them in safe mode. In the application event log, you see:
Log Name: Application
Source: Application Error
Date: 12/10/2009 11:33:03 AM
Event ID: 1000
Task Category: (100)
Level: Error
Keywords: Classic
User: N/A
Computer: HP-6510B-BE.domain.local
Faulting application WINWORD.EXE, version 12.0.6514.5000, time stamp 0x4a89d533, faulting module x2upBF.dll, version 5079.500.0.0, time stamp 0x4831cc55, exception code 0xc0000005, fault offset 0x000578ca, process id 0x17d8, application start time 0x01ca79b66b555f89.

In each case, it's been Office 2007 SP2 running on Vista (three times on SP2, once on SP1) and in each case it's been on the same LAN running with a single SBS 2003 Premium server. I'm able to fix the issue each time by recreating the user's profile. In one case, the problem returned on one user's machine (happening first one SP1 then several weeks later after I had upgraded to SP2).

Today, I had my fourth instance of this error - but I got some new information. I had remoted into this user's machine over the weekend and updated his Acrobat Standard to 8.1.7 and installed 10 Windows updates:

After troubleshooting the latest computer, where I knew for sure what I had changed, I did a system restore to a couple days before I made these changes (Acrobat upgrade and 10 updates installed). I successfully upgraded the Acrobat Standard to 8.1.7 (the latest version) and Word and other Office 2007 programs seem stable. I'll install the Windows Updates one by one over the next couple of days to see if one of them is the cause of the trouble.

In each case before this, I guess I had not attempted a system restore (though I could have sworn I would have as that's a normal part of troubleshooting and my memory says I did). But as previously mentioned, I solved the problem by recreating the user's profile (as the problem seemed to be isolated to a certain user's profile) and copying all their data back and setting their profile up again.

EDIT: On the machine where I observed the error, I later installed just KB949810. Office progarms worked fine after that. On a different machine (also Vista SP2 with Office 07 SP2), I installed KB973917, KB976884, KB976325, KB970430, KB976416, KB890830, KB905866, KB974318, KB973917.

EDIT: 1/4/10 - On another machine - I got this same issue. Same client, never seen it anywhere else. This is a machine that has not had this issue before. However, the updates were last installed on this machine on 12/14/09. I did a system restore to 1/2/10 - when the problem was not occurrung - but Word and other Office apps still crashed complaining of x2upBF.dll. So I'll go about my standard process of deleting and recreating the user's profile.


Intransigent said...

Any update on this? I've encountered the same problem. Quite stubborn. I agree it seems limited to a specific user profile.

Dave M said...

no updates on this at all. I still get it one or two times per month among a group of about 4 different machines - all Vista with office 2007 - and all on this one particular network.

This is the only client I have with this issue - and I have idea what the cause is. I can't help but thing it's somehow coming from the SBS 2003 server. I'm hoping it'll be resovled in the next month when I migrate their DC to a Windows 2008 box with Exchange 2010.