Thursday, September 11, 2008

changing permissions as needed for exmerge to work

When you download exmerge, it doens't work - which is stupid. First you have to copy the files to %Program Files%\Exchsrvr\bin so that it can find all the necessary DLLS. But then you have to change some permissions on the information store.

This page talks about it, but not completely:

Basically, it works like this. Open Exchange System Manager. Drill down to First Storage Group and then Mailbox Store. Right click on Mailbox Store and choose Properties. Go to the security tab. Click Advanced. Uncheck "allow inheritable permissions from the parent . . . " and choose copy.

Click OK. If you get a warning about permissions and denying permissions or number of permissions, so be it.

Now, for each user AND EACH GROUP THEY BELONG TO clear the deny right for send as and receive as.

So when I wented to allow the administrator user to do an exmerge, I cleared the deny box for send as and receive as for:

domain admins
enterprise admins

After I did that, I was able to do an exmerge.

No comments: