Friday, October 26, 2007

Dell Latitudes and disabled NICs

One thing I've had trouble with off and on is that Dell laptops with Broadcom network cards disable the NIC when you unplug the power cord and a network cord is not in. This can create problems when you have users who work on a wired connection at their office and then take their laptop home and work wirelessly on battery and then bring their laptops back in. When you clod boot a computer, the NIC comes back on, but if the laptop was asleep, in my experience it does not.

Personally, I've always preferred to just disable that power saving feature. The Broadcom applet in the Control Panel doesn't do it, so I have found the best way to do it is to do this:

Unplug the network cable
Unplug the power cable
For about 3 seconds a Broadcom window will come up that will say "your internal network card has been deactivated. Click here to change preferences"
And then you tell it to "always activate on battery"

You can do this in the dock or not in the dock.

No comments: