Saturday, October 3, 2009

Exchange 2007/2010 sending emails in RTF and winmail.dat attachments

Just corrected a stupid issue on an Exchange 2007 server where my users were sending emails to external recipients in rich text format (RTF) - even though the users were specifically choosingto send emails in HTML format. And part of what makes RTF a terrible format for email is that non-Outlook users receive all emails as winmail.dat files - which is how this problem presented itself. There is a setting in Exchange 2007/2010 where messages sent to certain external recipients in certain situations will always be converted to RTF no matter what the original format the message was sent in.

After investigating, I found this to be DEFAULT behavior in this scenario:
1) you are sending to an external contact defined in Exchange Management Console
2) the contact you are sending to does not use Outlook

To resolve it, you need to edit the properties of the contact. There is a field on the general tab for "Use MAPI rich text format." It should be changed from "use default settings" to "never"


You can also fix this universally for all users (by changing the default settings) in EMC > Organization configuration > hub transport.  On the Remote Domains tab, right click on Default and choose Properties.  Click on the message format tab and choose "Never use"


6 comments:

Fernando Madruga said...

I know this is an old post but what I've been trying to find for quite some hours now with no success, is how to change what UseDefaultSettings maps to, that is, I want to leave the contacts with UseDefaultSettings but change that Default to Never so that new contacts created will 'inherit' that new default value of never. Is that possible, or UseDefaultSettings is simply a "use hard-coded-settings-that-you-can't-change" thing?

Fernando Madruga said...

Never mind, just discovered how, seconds after previous post and after several hours of searching! :)

For others to use, here's how: http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_23079328.html

lee woo said...
This comment has been removed by a blog administrator.
Cindy Dy said...
This comment has been removed by a blog administrator.
Hector Gonzalez said...

Thank you for the post. I changed this on the Exchange Server and did my test and all works fine now. Thank you once again.

Leslie Lim said...

It is great to have the opportunity to read a good quality article with useful information on topics that plenty are interested on.

www.imarksweb.org